由于windows和Linux系统的差异性,python在windows下安装mysql会提示Microsoft Visual C++ 14.0 is required,很多人按照提示点开了链接,无奈报了个404,也有人费尽周折安装了Visual Studio。

今天偶然发现其实有现成编译好的包用,废话少说,附上链接:

下载地址:https://www.lfd.uci.edu/~gohlke/pythonlibs/#mysql-python

在上图找到合适的版本下载下来(cp36代表python版本是3.6)

我把文件放在了E盘根目录,所以打开cmd执行下面的命令:

pip3 install E:\mysqlclient-1.3.13-cp36-cp36m-win_amd64.whl

安装完验证一下,OK,没有报错